Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Help & Support for DHTML Menu Version 5+
Forum Topic: Click to view post
Last Updated: Thursday April 17 2014 - 06:04:03

IE 11 broke my submenus


Poster: cnckeith
Dated: Thursday November 21 2013 - 17:12:14 GMT

hello. IE 11 broke my submenus. i'm using Version 5.742. my guess is the solution to IE11 problem is to update to the latest milonic version.. but before i do that i though i'd just ask if anyone else has this issue and what they did to solve it.

here is the problem menu when using IE11. http://www.centroidcnc.com/zindex.html
this page works in most everything else. any advice would be much appreciated. thanks in advance. Keith

Attachment:
millonic.JPG

Re: IE 11 broke my submenus


Poster: Andy
Dated: Thursday November 21 2013 - 17:30:01 GMT

Hi Keith,

The problem is in the way IE11 no longer defines itself as Internet Explorer - Any version.

The reason for this is so that it can become more compatible with other browsers and web standards etc. IE11 now claims to be a browser very similar to Firefox.

It's a nice idea from Microsoft but in reality it still doesn't work. Hence the reason the older versions of the menu is broken. If Microsoft had successfully emulated Firefox the menu WOULD work, but as you've seen it doesn't. It doesn't just affect our software it's quite a widespread issue.

I do know of many IE specific problems that still exist in IE11 but Microsoft, in their arrogance, have now made it almost impossible to determine what browser it is.

Unfortunately, the only way to fix the menus is to upgrade. We've added some code to detect IE11 and fix the issue that still exist.

One other way is spoofing the browser User Agent but you can't really expect your website visitors to do the same.

Andy

Re: IE 11 broke my submenus, update fixed it..but now lic pr


Poster: cnckeith
Dated: Thursday November 21 2013 - 17:37:20 GMT

Andy,

thanks for the fast response. must be frustrating as a programmer to keep up with the craziness:-).. I downloaded the latest version. Version 5.937 and uploaded these two files. milonic_src.js and mmenudon.js and it fixed the IE11 submenu issue.. great..

but now if have the "JavaScript Menu, DHTML Menu Powered By Milonic" at the top of my pages. I did buy a lic years ago for our site, do i need to buy another for the new version? thanks, keith

Re: IE 11 broke my submenus, update fixed it..but now lic pr


Poster: Andy
Dated: Thursday November 21 2013 - 17:50:31 GMT

cnckeith wrote:
must be frustrating as a programmer to keep up with the craziness:-)


Yes, it's an absolute nightmare and only going to get worse. No longer do we need to test for desktop PC's but we need to test on smartphones, tablets, TV's, games consoles.....the list goes on. On top of that we have different flavours of phone/tablet os's. It's crazy all right :D

cnckeith wrote:
do i need to buy another for the new version?


I'm afraid so. It helps fund future development (we have a new product hopefully being released before the end of this year, current customers will get a great deal on that if you want it) and keeps our servers running.

Cheers,
Andy

Re: IE 11 broke my submenus


Poster: cnckeith
Dated: Thursday November 21 2013 - 18:22:48 GMT

sounds like a good deal. thanks again for the quick response, it really helps when you know there is someone there to answer a question.

Re: IE 11 broke my submenus


Poster: cnckeith
Dated: Thursday November 21 2013 - 18:33:04 GMT

ok i bought the lic , downloaded the licensed version, uploaded milonic_src.js and mmenudom.js to my site and i still get the "JavaScript Menu, DHTML Menu Powered By Milonic" at the top of the page.
what did i do wrong? thanks, Keith centroidcnc.com

Re: IE 11 broke my submenus


Poster: Andy
Dated: Thursday November 21 2013 - 18:48:20 GMT

Hi Keith,

Thanks very much for your support, it's most appreciated.

If you still see the forced link, then you must be looking at the old files still. The licensed files don't contain any code to include the forced link.

One common problem is browser cache. You might have the old files stored within the browser on your computer. A full browser refresh might fix things.

If you let me have a link to the problem I'll take a look.

-- Andy

Re: IE 11 broke my submenus


Poster: cnckeith
Dated: Thursday November 21 2013 - 19:01:07 GMT

observation....below is what i have been using for some time
the last line is the forced link i presume.. oddly.. it doesn't show up on the pages with the old version milonic_src.js and mmenudom.js in use.. just when i replace milonic_src.js and mmunudom.js with the latest version does the force link show up on the pages.

here is my milonic code for each page..

<script type="text/javascript" src="/milonic_src.js"></script>
<script type="text/javascript">
if(ns4)_d.write("<scr"+"ipt type=text/javascript src=/mmenuns4.js><\/scr"+"ipt>");
else _d.write("<scr"+"ipt type=text/javascript src=/mmenudom.js><\/scr"+"ipt>");
</script>
<script type="text/javascript" src="/menu_data_main_new.js"></script>
<div class=milonic>
<div align="center"><a href="http://www.milonic.com/">JavaScript Menu, DHTML Menu Powered By Milonic</a></div>

Re: IE 11 broke my submenus


Poster: cnckeith
Dated: Thursday November 21 2013 - 19:06:38 GMT

thanks for the advice..fyi..i did double check that i have properly uploaded the new milonic_src.js and mmenudom.js and i have cleared cache and tried on several browsers and still get the message.

Re: IE 11 broke my submenus


Poster: Andy
Dated: Thursday November 21 2013 - 19:45:42 GMT

There must have been code in the old menu to hide the class named "milonic" that's not there now.

You can probably remove the link if it will help.

Are your web pages static? or are they built using a template?
The reason I ask is that if it's a major job to remove the links to milonic.com on your pages, I can probably come up with something to help.

Re: IE 11 broke my submenus


Poster: cnckeith
Dated: Thursday November 21 2013 - 20:19:23 GMT

yeah..unfortunately they are static. (its an old site ). if its not too much trouble for you to come up with something so i don't have to edit a ton of pages that would be fantastic.

Re: IE 11 broke my submenus


Poster: Andy
Dated: Friday November 22 2013 - 9:27:00 GMT

Hi Keith,

Here's a workaround:

Edit milonic_src.js and add this to the end of the file:

Code:
_d.write("<style>.milonic{width:1px;visibility:hidden;position:absolute}</style>");


If you have trouble getting this to work, or if it corrupts milonic_src.js, let me know and I'll have another think.

HTH,
Andy

Re: IE 11 broke my submenus.. thanks so much. fixed


Poster: cnckeith
Dated: Friday November 22 2013 - 16:43:00 GMT

Andy,

thanks so much.. that seems to have done it. wow that saved me alot of pages to track down and edit.
i really appreciate the help. can't wait to see the new stuff coming out. good luck.
talk to you when IE12 comes out :-)) -Keith

Re: IE 11 broke my submenus


Poster: ghis
Dated: Thursday January 30 2014 - 19:51:24 GMT

Hi there,

I have the same problem on the second level menus.

I have tried this solution of editing milonic_src.js with:
_d.write("<style>.milonic{width:1px;visibility:hidden;position:absolute}</style>");


It works only the first time the page is loaded (test page at : http://www.wunderkammern.net/index2.htm )

Then if I roll out and back on again it stops working.

Thanks for your advice.

Best
G

Re: IE 11 broke my submenus


Poster: ghis
Dated: Friday January 31 2014 - 7:28:22 GMT

Hi there!

I have just updated my license and downloaded the latest menu version!

The fix with :
_d.write("<style>.milonic{width:1px;visibility:hidden;position:absolute}</style>");

is working OK now!

Great!

Thank you for the support!

best
G

Re: IE 11 broke my submenus


Poster: Ruth
Dated: Friday January 31 2014 - 23:40:43 GMT

I'm glad that fixed it. Post back if you need any help. Maybe the next time the board will send me my notice :) Oh we so depend on tech :lol: I guess I should start checking every day, after all it only takes 20 secs!

Ruth

Re: IE 11 broke my submenus


Poster: Andy
Dated: Monday February 3 2014 - 11:51:44 GMT

Ruth wrote:
Maybe the next time the board will send me my notice :)


I'll see what I can do ;)