Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Help & Support for DHTML Menu Version 5+
Forum Topic: Click to view post
Last Updated: Thursday February 8 2018 - 06:02:07

Submenu Position


Poster: Anonymous
Dated: Monday December 29 2008 - 3:08:17 GMT

My menu is located at http://lastborns.surf.to but I'm not having any problems with it but:

When I visit the site without ad blocking tools, the menu does not really appear where I like it to. So I'm wondering if there is a way to make all sub menu's pop upward rather than down and to the right ? I ask because I think I'd like to try placing the main menu on the bottom of the page.

Thanks for any help and this is by far the best menu, been using it for 7+ years now.

Re: Submenu Position


Poster: Anonymous
Dated: Monday December 29 2008 - 20:58:18 GMT

Well, I guess it's not possible!

And the post by Ruth pointing to viewtopic.php?f=10&t=8777 must be for me. I will study it and correct my use of the menu in tables.

Sorry for not reading it prior to posting but if it's any consolation, I did search for an answer first.

Also, after reading the link back for free use, I updated all my pages to comply as it has been years since I came here.

Re: Submenu Position


Poster: Ruth
Dated: Monday December 29 2008 - 23:30:37 GMT

Hi,

I'm sorry, but your version is 4 years old, so there's no way I can do any support since the menu has changed a lot since then. You need to get the newest version for support. Make sure you do NOT save it where you have the existing files since you don't want to overwrite your menu_data file that you already have. Once you have that, if you can tell me where you want the menu I'd be glad to help. If you want it at the bottom and to scroll I'm pretty sure we can do that :)

Ruth

Re: Submenu Position


Poster: Anonymous
Dated: Tuesday December 30 2008 - 0:24:17 GMT

Hi and thanks for the support, Ruth.

I, at one time, had the full download. How do I get it again for the latest version because even after logging in it's only the evaluation one created.

Thanks.

Re: Submenu Position


Poster: Ruth
Dated: Tuesday December 30 2008 - 4:35:43 GMT

Hi,

It may be that it has been so long since you downloaded that the system is not recognizing that license.

1. Go to the main site http://www.milonic.com/index.php and try logging in again, and then go to the My Milonic tab on the menu and then down to My Licenses and see what info you get there. It should tell you your license number, the type of license and when it expires. There is also a place to check and then a tab to click for renewing the license. See if that will do it.

2. If that doesn't do anything for you, then try http://www.milonic.com/contactus.php? and include your license number and the type i.e. free and ask how you get the newest version since you can't seem to download any but the evaluation one.

Ruth

Re: Submenu Position


Poster: Anonymous
Dated: Tuesday December 30 2008 - 6:45:22 GMT

I tried logging in an older e-mail address and it worked. I'm now working with the latest full release.

Thanks for the help thus far.

Re: Submenu Position


Poster: Ruth
Dated: Tuesday December 30 2008 - 17:48:59 GMT

That's great.

1. log in on that name again and go to the My Milonic and go to view/edit my details then at the bottom of the page you can click the link to change things and put in the correct email address.

2. go to this topic and mark it to subscribe or watch this topic and you'll get notification when new versions come out
viewtopic.php?f=10&t=3108

Now, how is it you want the menu? Is there a way you can put up a test page using the new version someplace so I can get it and then give me the info on how you want the menu and I'll get something for you.

Ruth

Re: Submenu Position


Poster: emeyada
Dated: Tuesday December 30 2008 - 19:11:08 GMT

This is selvan, made a mess of things re: the login to the board.

Your willingness to help is great, thanks.

Okay, I've got the newest version uploaded and the menu is called for in the table but why is it dropping and sliding to the left and why is the sub menus taking so long to show?

The menu is here http://members.lycos.co.uk/surfto/test/tweaks.htm

Re: Submenu Position


Poster: Ruth
Dated: Wednesday December 31 2008 - 3:25:27 GMT

Hi,

You have to upload all the program files, milonic_src.js, mmenuns4.js, mmenudom.js. That's the reason the subs aren't loading. The only file you don't upload is the menu_data.js file.

What did you mean made a mess of the login?

Also, how did you want to fix the menu? If you want it at the bottom of the page, and want it to open up and also to follow scroll still so that it will go down when someone scrolls that can be done. If you put it in a table, you can still make it open up for the submenus, but be aware, you cannot have it scroll and it will always be wherever that table is, so if someone has say 800x600 resolution [still a good percentage of people] the menu might be off the screen at the bottom and not visible unless they scroll down.

Anyway, just let me know how you want it and I'll see what I can do

Ruth

Re: Submenu Position


Poster: emeyada
Dated: Wednesday December 31 2008 - 4:50:58 GMT

Hi Ruth,

The menu is here http://members.lycos.co.uk/surfto/test/tweaks.htm

All the program files, including menu_data.js, are uploaded in a dir "menuother" and the subs do load but I have to mouse over several times before they do. And now with the menu called in the table, the followscroll works but when the page loads something is causing the menu to slide down and to the left. How do I stop it from doing that? I want it to be just above where it says "XP Pro & Firefox Tips, Tricks & Tweaks" at the top within the same table and centered.

Re: the login. Here on the board I had a login name "selvan". I changed the password then changed the e-mail address and accidentally entered one I can't access any longer. So I'll never be able to follow through with the change and am now no longer able to login using selvan.

Thanks to you, I now know I need to call for the menu within the table. Because of that I no longer have a wish to place it on the bottom.

Thanks.

Re: Submenu Position


Poster: Ruth
Dated: Wednesday December 31 2008 - 6:36:07 GMT

Hi,

You have a problem on your site. The milonic_src file at

Code: Select all

http://lastborns.surf.to/menuother/milonic_src.js
is version 5.813, however the other files up there, the mmenudom.js file and the mmenuns4.js file are still the 5.68 version. You cannot mix versions. All the files at the menuother [except your menu_data.js file] have to be from the newest download, they all have to be 5.813. I am suprised that the menu is showing at all with different versions of the program files.

Once you get the right files up there, the submenus should show just fine. Now, as to the menu in the table, if you want it to be centered in the table, the best way to do that is to put a single cell table right at the top of the existing TD that has that XP PRO thing in it where you want the menu above it and put the call for the menu into that table, setting the table to center, not the menu. Because you are putting it in a table it is relatively positioned and it should NOT scroll, though it seems that it is doing that. I believe that is whats causing a lot it not to be at the top of the table as you want. Try putting this as your code for the menu. You are going to put it after this line of that table

Code: Select all

<TD
    style="PADDING-RIGHT: 5.75pt; PADDING-LEFT: 5.75pt; PADDING-BOTTOM: 0in; PADDING-TOP: 0in"
    vAlign=top>


Add this right after that line.

Code: Select all

<br><table cellpadding=0 cellspacing=0 border=1 bordercolor=lime align='center'>
<tr>
    <td><script  type="text/javascript" src="menuother/milonic_src.js">
  </script><script  type="text/javascript">

if(ns4)_d.write("<scr"+"ipt type=text/javascript src=menuother/mmenuns4.js><\/scr"+"ipt>");      
  else _d.write("<scr"+"ipt type=text/javascript src=menuother/mmenudom.js><\/scr"+"ipt>");
  </script><script  type="text/javascript" src="menuother/menu_data.js">
  </script><script  type="text/javascript" src="menuother/tooltips.js">
  </script></td>
</tr>
</table>


This will be just above the stuff for the XP Pro & Firefox Tips, Tricks & Tweaks

FINALLY, go into the menu_data.js file and remove that followscroll. It should not be there in a menu that is relatively positioned. Relative position means it stays where it is put no matter how the resolution changes, so wherever that table is at whatever resolution, the menu will always be there :)

I sent you an email to this name. I can fix your Selvan name, reset the password and reset the email if you send me the email address to use. Once I reset the password, I'll send it to you at whatever email address you give me, and then you can go in and change it to what you want it to be when you log on again.

Ruth

Re: Submenu Position


Poster: selvan777
Dated: Wednesday December 31 2008 - 8:19:32 GMT

Hi Ruth,

I'm real sorry but all the modules at http://members.lycos.co.uk/surfto/test/menuother are 5.813. And the call for the menu at test/tweaks.htm point to them. Any other idea on how to fix the sub menu's and prevent the main menu from dropping down? I managed to center it using the code screenposition="center"; I really can't do without the followscroll option at tweaks.htm so placing the menu in it's own table is out.

I've applied the use of the menu in it's own table on the main page at http://lastborns.surf.to where not having followscroll is okay. But when I use the 5.813 modules for that page the same behavior happens there too with the sub menu's not showing and the main menu dropping so I am still using the older modules there.

Thanks.

Re: Submenu Position


Poster: selvan777
Dated: Wednesday December 31 2008 - 23:37:36 GMT

Well, I did all that you said, including taking out screenposition, except for using your <TD... tag, it didn't work for me. But I did create a table there and placed the menu call in it. The menu is centered but, as expected, it does not scroll due to relative as you said.

However, the bigger issue is that the sub menu's still have the same problem.

The menu again is here http://members.lycos.co.uk/surfto/test/tweaks.htm

Thanks

Re: Submenu Position


Poster: Ruth
Dated: Thursday January 1 2009 - 4:36:02 GMT

Hi,

You need to change your menu data file everyplace where you have the onfunction=showtip. In the exsiting aI strings that use this

Code: Select all

onfunction=showtip('Best viewed with 1400x1050 screen resolution');


change it to

Code: Select all

tooltip=Best viewed with 1400x1050 screen resolution;


See if that fixes the problem. I have a feeling there might be something in that because FF is giving me an error with regard the tooltips module, so Ithink it might be the onfunction=showtip, instead of tooltip= in the aI strings. Sorry, I forgot to mention that part :oops:

Ruth

Re: Submenu Position


Poster: selvan777
Dated: Saturday January 3 2009 - 10:49:09 GMT

Thanks Ruth, that did it.