Milonic provide full featured pull down web menus for some of the worlds largest companies
click here to see what it can do for you

Download Milonic DHTML Menu
Buy Milonic DHTML Menu

Back To Start Of Archive
Taken From The Forum: Help & Support for DHTML Menu Version 5+
Forum Topic: Click to view post
Last Updated: Friday January 19 2018 - 06:01:05

Problems with what appears to be z-index.


Poster: rpetrisca
Dated: Thursday December 10 2009 - 0:50:37 GMT

It appears as if the milonc menu drops down behind other objects. In a weird way. Sometimes it does and sometimes it doesn't (see samople photos below).
It appears to function correctly in IE 6 and older versions of firefox. But not IE 7, IE 8, and Firefox 3.5.

ie 7 and ie 8 (strange)
Drops down behind milonc left side menu sometimes.
image: Image from site: http://currentstudents.ajula.edu/

The same page this time it does not drop down behind.
image: Image from site: http://currentstudents.ajula.edu/

ie 7 and ie 8 (another sample)
Drops down behind form controls.
image: Image from site: http://giving.ajula.edu/Content/forms/donatenew.asp?CID=57&t=0

In firefox v3.5.5 (also occurs in firefox)
Drops down behind embeded video.
image: Image from site: http://bci.ajula.edu/

We are using Milonic Version 5.796 - Built: Thursday June 19 2008 - 16:12

Could anybody help :?:

Re: Problems with what appears to be z-index.


Poster: Ruth
Dated: Thursday December 10 2009 - 8:40:23 GMT

Hi,

I can't see any of the first issues. I can only suggest you try changing buildAfterLoad to true and see if that might fix what is happening. It sounds as if, when it drops behind, that the menu isn't completely loaded yet. But, since I can't reproduce it, I can only guess.

As to the video issue, you need to add wmode='transparent' to your tag, i.e.

Code: Select all

width=560 height=340 wmode='transparent'
I did that and the menu dropped over the video in IE6, 7, FF 1.5, 2.0.0.18, 3.something, Opera 9.5, Google Chrome, I couldn't test in NN7.2 nor in Safari because it won't allow me to load a page from the desktop and then call the embed file from the web, but I have to assume it will work in those also.

You also need to try upgrading your menu, you are way downlevel.

Ruth